Gem Error When Installing Rails

Gem Error When Installing Rails

So, I’m finally getting around to learning Ruby. (Thanks, I’m pretty excited myself.) While following Dan Benjamin’s excellent Building Ruby, Rails, LightTPD, and MySQL on Tiger over at HiveLogic, I encountered the following error:

$ sudo gem install rails --include-dependencies Bulk updating Gem source index for: http://gems.rubyforge.org ERROR: While executing gem ... (Gem::GemNotFoundException) Could not find rails (> 0) in any repository

Yeah, it didn’t make any sense to me either. So after a bit of Google-fu, I stumbled upon this post on Aral Balkan’s blog. The last post from Wilson is the important one:

Hey… I’m experiencing the same problem. I’ve spent about two days playing with this. I think i might’ve finally figured out the solution: %gem cleanup %sudo gem update

I’m not convinced the gem update does anything on a new install (such as mine), but I threw caution to the wind and did it. Afterwards, the gem install rails command worked perfectly.

    Related Posts